Uploaded image for project: 'CFEngine Community'
  1. CFEngine Community
  2. CFE-1757

Package policy "reinstall" and "delete" should repair on package_select => "!=".

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Rejected
    • Priority: Medium
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Promise type: packages
    • Labels:
      None

      Description

      E.g.:

      package foo installed is version 1

      "foo" package_select => "!=", package_version => "1.1", package_policy => "delete";

      Package should be deleted because it is not equal to 1.1.

      E.g.:

      Package foo installed is version 2.2. Desired version is 2.1.

      "foo" package_select => "!=", package_version => "2.1", package_policy => "delete";

      Package should be deleted, then installed with version 2.1 requested.

        Attachments

          Activity

            People

            • Assignee:
              a10040 Kristian Amlie
              Reporter:
              bahamat Brian Bennett
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Summary Panel