Uploaded image for project: 'CFEngine Community'
  1. CFEngine Community
  2. CFE-1824

CompareVersions: Checked whether package version 2.15-0ubuntu10.5 < 2.15-0ubuntu10.10: no is worng

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Done
    • Priority: Medium
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Promise type: packages
    • Labels:
      None
    • Platform:
      Ubuntu
    • Steps to reproduce:
      Manual steps provided

      Description

      On a pristine Ubuntu 12.04 this promise does not upgrade the existing libc6 package which is 2.15-0ubuntu10.5

      @ packages:
      "libc6"
      package_policy => "addupdate",
      package_select => ">=",
      package_version => "2.15-0ubuntu10.10";@

      Verbose output shows the following:

      @2015-01-28T23:08:52+0000 verbose: /default/main/methods/'any'/default/base_packages/packages/'libc6'[0]: Package promises to refer to itself as 'libc6' to the manager
      2015-01-28T23:08:52+0000 verbose: /default/main/methods/'any'/default/base_packages/packages/'libc6'[0]: Package version seems to match criteria
      2015-01-28T23:08:52+0000 verbose: /default/main/methods/'any'/default/base_packages/packages/'libc6'[0]: Package method does NOT specify a file repository
      2015-01-28T23:08:52+0000 verbose: /default/main/methods/'any'/default/base_packages/packages/'libc6'[0]: Checking if latest available version is newer than installed...
      2015-01-28T23:08:52+0000 verbose: /default/main/methods/'any'/default/base_packages/packages/'libc6'[0]: Looking for an installed package older than (libc6,2.15-0ubuntu10.10,*) [name,version,arch]
      2015-01-28T23:08:52+0000 verbose: /default/main/methods/'any'/default/base_packages/packages/'libc6'[0]: Found installed package (libc6,2.15-0ubuntu10.5,default) [name,version,arch]
      2015-01-28T23:08:52+0000 verbose: /default/main/methods/'any'/default/base_packages/packages/'libc6'[0]: Check for compatible versioning model in (2.15-0ubuntu10.5,2.15-0ubuntu10.10)
      2015-01-28T23:08:52+0000 verbose: /default/main/methods/'any'/default/base_packages/packages/'libc6'[0]: Verified that versioning models are compatible
      2015-01-28T23:08:52+0000 verbose: /default/main/methods/'any'/default/base_packages/packages/'libc6'[0]: CompareVersions: Checked whether package version 2.15-0ubuntu10.5 < 2.15-0ubuntu10.10: no
      2015-01-28T23:08:52+0000 verbose: /default/main/methods/'any'/default/base_packages/packages/'libc6'[0]: Installed package is up to date, not updating@

      Changing package version to 2.15-0ubuntu11 will successfully upgrade.

        Attachments

          Activity

            People

            • Assignee:
              a10053 Marcin Pasinski
              Reporter:
              malford Matt Alford
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Summary Panel