Uploaded image for project: 'CFEngine Community'
  1. CFEngine Community
  2. CFE-1979

AIX package cannot be installed due to corrupt package header

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Done
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.7.0
    • Labels:
      None
    • Platform:
      AIX

      Description

      <pre>
      bash-4.3# installp -a -d `pwd`/cfengine.cfengine-nova-3.7.0.0.bff cfengine.cfengine-nova
      0503-005 installp: The format of the toc file is invalid.
      0503-019 installp: cfengine 3.7.0b1.0 is an invalid level.
      ALL levels must be in one of the following formats:
      vv.rr.mmmm.ffff OR vv.rr.mmmm.fffff.ppppppppp
      0503-005 installp: The format of the toc file is invalid.
      </pre>

      This may be simply because the "b1" is not allowed in the version. But didn't we do this before?

        Attachments

          Activity

            People

            • Assignee:
              a10040 Kristian Amlie
              Reporter:
              a10040 Kristian Amlie
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Summary Panel