Uploaded image for project: 'CFEngine Community'
  1. CFEngine Community
  2. CFE-2300

"could not open cf_lock.lmdb" on heavily loaded hub on FreeBSD

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Done
    • Priority: Medium
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.9.0, 3.7.4
    • Component/s: Internal Databases
    • Labels:
      None

      Description

      After upgrade from 3.5.3 to 3.7.2(lmdb 0.9.17) at FreeBSD 9.3 amd64, I have seen strange errors in top.

      cfe 3.5.3 does not generate this errors.

      top -m io :

      ast pid: 47991; load averages: 0.81, 0.58, 0.58 up 0+04:23:44 14:17:28
      58 processes: 1 running, 57 sleeping
      CPU: 8.3% user, 0.0% nice, 3.4% system, 0.1% interrupt, 88.2% idle
      Mem: 157M Active, 7187M Inact, 687M Wired, 86M Cache, 1307M Buf, 7726M Free
      Swap: 16G Total, 16G Free

      PID USERNAME VCSW IVCSW READ WRITE FAULT TOTAL PERCENT COMMAND
      48093 root 29 1 0 16 444 460 91.82% cf-agent
      41735 root 772 1 0 29 12 41 8.18% cf-serverd

      Only cfengine processes generate this fault errors.

      What can it be and how to avoid or fix them ?

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                a10040 Kristian Amlie
                Reporter:
                fatin test test (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel