Uploaded image for project: 'CFEngine Community'
  1. CFEngine Community
  2. CFE-2360

--force-yes has been deprecated on recent distros

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Done
    • Priority: Low
    • Resolution: Fixed
    • Affects Version/s: 3.8.2
    • Fix Version/s: 3.7.5, 3.11.0, 3.10.2
    • Component/s: Promise type: packages
    • Labels:
    • Environment:
      cfengine-community 3.8.2-1 running on Ubuntu 16.04.
    • Story Points:
      3
    • Platform:
      Ubuntu
    • Steps to reproduce:
      Not provided

      Description

      I get the following warning when running a package promises on Ubuntu 16.04 (apt-get version 1.2.10).

      W: --force-yes is deprecated, use one of the options starting with --allow instead.

      From the man pages for apt-get.

             --force-yes
                 Force yes; this is a dangerous option that will cause apt to continue without prompting if it is
                 doing something potentially harmful. It should not be used except in very special situations.
                 Using force-yes can potentially destroy your system! Configuration Item: APT::Get::force-yes. This
                 is deprecated and replaced by --allow-downgrades, --allow-remove-essential,
                 --allow-change-held-packages in 1.1.
      

        Attachments

          Activity

            People

            • Assignee:
              a10042 Nick Anderson
              Reporter:
              ragnar Ragnar
            • Votes:
              2 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Summary Panel