Uploaded image for project: 'CFEngine Community'
  1. CFEngine Community
  2. CFE-2894

Travis fails to install cfengine and masterfiles cannot be tested

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Done
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.12.1
    • Component/s: None
    • Labels:
      None

      Description

      All of the masterfiles PR builds are failing travis. It seems that it is unable to install cfengine-community because of unauthenticated sources.

      https://travis-ci.org/cfengine/masterfiles/jobs/425414188

      Installing APT Packages
      $ export DEBIAN_FRONTEND=noninteractive
      3.19s$ sudo -E apt-get -yq update &>> ~/apt-get-update.log
      0.74s$ sudo -E apt-get -yq --no-install-suggests --no-install-recommends $TRAVIS_APT_OPTS install cfengine-community
      Reading package lists...
      Building dependency tree...
      Reading state information...
      The following NEW packages will be installed:
        cfengine-community
      0 upgraded, 1 newly installed, 0 to remove and 241 not upgraded.
      Need to get 5,044 kB of archives.
      After this operation, 19.3 MB of additional disk space will be used.
      WARNING: The following packages cannot be authenticated!
        cfengine-community
      E: There were unauthenticated packages and -y was used without --allow-unauthenticated
      
      

        Attachments

          Activity

            People

            • Assignee:
              Aleksei Aleksei Shpakovskii
              Reporter:
              a10042 Nick Anderson
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Summary Panel