Uploaded image for project: 'CFEngine Community'
  1. CFEngine Community
  2. CFE-920

sys.flavour doesn't know many new distributions

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Done
    • Priority: Medium
    • Resolution: Fixed
    • Affects Version/s: 3.6.0
    • Fix Version/s: 3.11.0
    • Component/s: None
    • Labels:
      None
    • Found in version (details):
      3.5.2

      Description

      I think the intel of sys.flavour is very limit. We should ensure that sys.flavour at least support current/latest official linux distributions (rpm/deb) we have on the web such as Debian, Ubuntu, Redhat, Suse. (Linux Mint is large so we should considering to do that too.)

      On Ubuntu 13.10, sys.flavour displays "ubuntu_Saucy Salamander (development branch)" (expected to see "ubuntu_13")

      This breaks binary upgrade process on Enterprise version.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                a10040 Kristian Amlie
                Reporter:
                a10005 Nakarin Phooripoom (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Summary Panel