Uploaded image for project: 'Mender'
  1. Mender
  2. MEN-3606

[testing]: Make demo mode work for Enterprise

    XMLWordPrintable

    Details

    • Days in progress:
      7

      Description

      Acceptance criteria:

      • --enterprise-testing argument added to demo script, causing the demo to be launched in Enterprise mode
        • Flag should not be listed on help screen (it is internal, for our testing)
      • When using argument, the script must create a tenant and a user, and must upload the demo artifact, as for the Open Source mode
      • A test is appreciated (maybe adapting the existing one), but not required, since it is only for our own use

      Original task description, before repurposing:

      Title: Mender Enterprise onboarding demo-mode does not have the prebuilt Mender artifact

      I am now able to connect my device to the Mender Enterprise demo server using 2.4.0b1-build2 with the fix shown in https://github.com/mendersoftware/gui/pull/713 but after the device is accepted, the popup directs me to the "Releases" tab which is empty.

        Attachments

          Activity

            People

            • Assignee:
              a10040 Kristian Amlie
              Reporter:
              drewmoseley Drew Moseley
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Summary Panel