Uploaded image for project: 'Mender'
  1. Mender
  2. MEN-3675

Log says "Certificate expired or not yet valid" when root CA is missing

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Low
    • Resolution: Unresolved
    • Affects Version/s: 2.2.0
    • Fix Version/s: None
    • Environment:
      Custom Buildroot OS
    • Days in progress:
      0

      Description

      When integrating Mender with my C.H.I.P. board, I came across the Certificate expired or not yet valid error. I adjusted the time and date on my C.H.I.P., but Mender would still spit out this error.

      I later figured out that I was missing the ca-certificates package on my board and my certificate chain was untrusted. Installing root CA certificates solved the issue.

      However, I file this (low priority) bug report since the Mender log output is clearly wrong.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              Risca Patrik Dahlström
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:

                Summary Panel