Uploaded image for project: 'Mender'
  1. Mender
  2. MEN-3807

[ui][2.4.0-build4] incorrect pending deployments (dashboard)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: (None)
    • Resolution: Unresolved
    • Affects Version/s: 2.4.0
    • Fix Version/s: None
    • Labels:
    • Backlog:
      no
    • Days in progress:
      0

      Description

      Context:
      QEMU device + enterprise backend onboarding testing

      completed onboarding, and completed 1 extra static deployment on the same device (with just a newer index.html file).

      now this is a heisenbug, so take with a grain of salt:

      occassionally, when looking at the dashboard, I got Pending deployments: 1. There were clearly no pending deployments, clicking on the widget took to to an empty 'pending list'.
      all previous deployments ended ~10 mins before.

      I got this on some page refreshses, and not others. the 'pending' dashboard counter sometimes was 0, sometimes 1.

      not sure how to reproduce, just do the onboarding and try your luck with clicking/ctrl+r - ing the dashboard page.

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            marcin.chalczynski Marcin Chalczynski
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:

                Zendesk Support