Uploaded image for project: 'Mender'
  1. Mender
  2. MEN-3975

Upgrade from 2.4.0 to 2.5.0 fails due to mongodb

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Done
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.4.0
    • Fix Version/s: None
    • Labels:
    • Environment:
      Debian with docker following the installation documentation
    • Days in progress:
      6

      Description

      Upgrading our mender enterprise server from 2.4.0 to 2.5.0 fails with:

      "Failed to start up WiredTiger under any compatibility version. This may be due to an unsupported upgrade or downgrade."

      It seems that mender 2.4.X uses mongodb version 3.6,

      whereas mender 2.5.0 uses mongodb 4.4.

       

      The update fails because according to mongodb docu, you must follow the upgrade path of

      3.6-> 4.0 -> 4.2 -> 4.4 for mongodb.

       

      We now upgraded to 2.4.1, but 2.5.0 still fails.

        Attachments

          Activity

            People

            • Assignee:
              kjaskiewicz Krzysztof Jaƛkiewicz
              Reporter:
              __martin__ Martin Steegmanns
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Summary Panel