Uploaded image for project: 'Mender'
  1. Mender
  2. MEN-4750

Configure: Import default configuration is broken

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Done
    • Priority: (None)
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0.0, 3.0.0-report
    • Labels:
    • Days in progress:
      1

      Description

      Under a Device -> Configuration, if I click "Import configuration" and "Import the current default configuration" followed by "Import" button the UI dialogue box seems to crash / become flaky and it just shows an empty configuration (even though I have checked the box to save a configuration earlier).

      I tested with both Firefox and Chrome (on current hosted Mender), so pretty sure it is a UI bug.

      At the same time I would like to propose a usability enhancement while working in this area, as discovered during user testing of the prototype and again while demoing it:

      Instead of "hiding" the import default configuration under "Import configuration", simply have a button to "Fill default configuration" at the top level. This would align conceptually with having a "Save as default" checkbox at the top level as well and have it more easily accessible.

        Attachments

          Activity

            People

            • Assignee:
              mzedel Manuel Zedel
              Reporter:
              a10003 Eystein Maloy Stenberg
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Zendesk Support