Uploaded image for project: 'Mender'
  1. Mender
  2. MEN-5765

Mender depends on libssl1.1 which is no longer available in Ubuntu 22.04

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Done
    • Priority: (None)
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.4.0
    • Labels:
    • Sprint:
      MEN Sprint 172
    • Story Points:
      0
    • Backlog:
      yes
    • Days in progress:
      0

      Description

      Ubuntu 22.04 dropped APT support for libssl1.1 and now only supports libssl3+, however mender client and mender-connect still make use of libssl1.1

      The current workarounds are not pretty, it is either:

      • echo "deb http://security.ubuntu.com/ubuntu focal-security main" | sudo tee /etc/apt/sources.list.d/focal-security.list
        sudo apt-get update
        sudo apt-get install libssl1.1
        rm /etc/apt/sources.list.d/focal-security.list
        

        or

      • wget http://archive.ubuntu.com/ubuntu/pool/main/o/openssl/libssl1.1_1.1.0g-2ubuntu4_amd64.deb
        sudo dpkg -i ./libssl1.1_1.1.0g-2ubuntu4_amd64.deb
        rm -i libssl1.1_1.1.0g-2ubuntu4_amd64.deb

       

      While these both work, they feel like short term workarounds.

      It would be great for Mender to move to libssl3.

        Attachments

          Activity

            People

            Assignee:
            lluis Lluís Campos
            Reporter:
            shaunco Shaun C
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: